Gsea enhancements

From GeneSetEnrichmentAnalysisWiki

(Difference between revisions)
Jump to: navigation, search
 
(37 intermediate revisions not shown)
Line 1: Line 1:
-
<span style="font-weight: bold;">On the GSEA Web Site:<br /></span><br />1. Doc page top menu has a different order than other pages:<br />&nbsp;&nbsp;&nbsp; Other:&nbsp; Home&nbsp; &circ;&nbsp;&nbsp;&nbsp; Software&nbsp; &circ;&nbsp;&nbsp;&nbsp; MSigDB&nbsp; &circ;&nbsp;&nbsp;&nbsp; GeneSetCards&nbsp; &circ;&nbsp;&nbsp;&nbsp; Documentation&nbsp; &circ;&nbsp;&nbsp;&nbsp; Resources&nbsp; &circ;&nbsp;&nbsp;&nbsp;&nbsp; <br />&nbsp;&nbsp;&nbsp; Doc:&nbsp;&nbsp;&nbsp; Home&nbsp; &circ;&nbsp;&nbsp; Documentation&nbsp; &circ;&nbsp;&nbsp; Software&nbsp; &circ;&nbsp;&nbsp; MSigDB&nbsp; &circ;&nbsp;&nbsp; GeneSetCards&nbsp; &circ;&nbsp;&nbsp; Resources&nbsp; &circ;&nbsp;&nbsp;&nbsp; <br /><br /><span style="color: rgb(51, 153, 102);">Done</span><br /><br />2. GSEA icon on doc page should link to GSEA home page (not doc page)<br /><br /><span style="color: rgb(255, 102, 0);">Unable to fix</span><br /><br />3. MSigDB page needs to point to license notice, as on V1 web site.<br /><br /><span style="color: rgb(51, 153, 102);">Done<br /><br /></span>4. Are we putting Java docs for GSEA application on the web site? Where are they?<br /><br /><span style="color: rgb(0, 0, 255);">Probably not unless someone asks</span><br /><br />5. Make the Contact Us page more prominent (add it to Resources page?). <br /><span style="color: rgb(51, 153, 102);">Done<br /><br /></span>6. On the Contact Us page, software credits and MSigDB credits should point to the appropriate wiki pages.<br /><span style="color: rgb(51, 153, 102);">Done<br /><br /></span>7. How should people cite GSEA and/or MSigDB in their papers (eg I used GSEA with my own gene set or the p53 gene set is enriched in my analysis)? We need to add this info to the Publications page (and to MSigDB page?).<br /><span style="color: rgb(0, 0, 255);">See email</span><br /><br />8. On the software download page (http://wwwdev.broad.mit.edu/gsea/software/software_download.html), incorrect link to GSEA-R zip file.<br /><span style="color: rgb(51, 153, 102);">Done<br /><br /></span>9. The title bar on the Gene Set Card pages is missing the GSEA logo and has the menu items in the wrong order (Doc before Software rather than before Resources). Since I notice that you've already fixed many of the above, perhaps it's just that I was looking while you were playing with the pages?<br /><br /><span style="color: rgb(255, 102, 0);">Next build will fix this </span><span style="font-weight: bold;"><br /><br /><br />Found 4/4:</span><br />1. Specify Bhattacharyya with Continous pheno, should get error 1011 (get hardcoded error). <span style="font-style: italic;">Metric for ranking genes</span> parameter.<br /><br /><span style="color: rgb(0, 0, 255);">Bhattacharyya is a continuous metric so isnt this correct?</span><br /><br />2. Specify Pearson with Categorical, should get error 1010 (get hardcoded error). <span style="font-style: italic;">Metric for ranking genes</span> parameter.<br /><br /><span style="color: rgb(0, 0, 255);">Pearson is allowed for categorical &amp; continuous</span><br /><br />3. Add Fold Change back into <span style="font-style: italic;">Metric for ranking genes</span> parameter drop-down list.<br /><br /><span style="color: rgb(51, 153, 102);">Done</span>. Its called 'Ratio_of_Means' to be more prcise on what fold change is.<br /><br /><br /><span style="font-weight: bold;"><span style="font-weight: bold;">Found 4/3 (Aravind's notes from Heidi's cube):</span></span><br style="font-weight: bold;" /><br />tool cache doesnt show up<br /><span style="color: rgb(51, 153, 102);">fixed</span><br /><br />tool cache wrong on errored out report<br /><span style="color: rgb(51, 153, 102);">fixed</span><br /><br />file chooser static<br /><span style="color: rgb(255, 0, 0);">No fix. Known limitation<br /><br /></span>installer must install databases/Hs.alias<br />installer must delete folder<span style="font-weight: bold;"><span style="font-weight: bold;"><br /></span></span><span style="color: rgb(51, 153, 102);">Made new software upgrade to v2 page</span><span style="font-weight: bold;"><span style="font-weight: bold;"><br /><br />Found 4/3 with new build:<br /></span></span>1. Attempt to run the leading edge analysis gives following error (Build HTML Report works fine): <br />java.lang.NoClassDefFoundError: org/apache/commons/math/MathException<br />&nbsp;&nbsp;&nbsp; at org.genepattern.gsea.LeadingEdgeAnalysis.&lt;init&gt;(LeadingEdgeAnalysis.java:127)<br />&nbsp;&nbsp;&nbsp; at org.genepattern.gsea.LeadingEdgeWidget.runAnalysis(LeadingEdgeWidget.java:341)<br />&nbsp;&nbsp;&nbsp; at org.genepattern.gsea.LeadingEdgeWidget.access$400(LeadingEdgeWidget.java:59)<br />&nbsp;&nbsp;&nbsp; at org.genepattern.gsea.LeadingEdgeWidget$4.run(LeadingEdgeWidget.java:313)<br />&nbsp;&nbsp;&nbsp; at foxtrot.AbstractWorkerThread$2.run(AbstractWorkerThread.java:49)<br />&nbsp;&nbsp;&nbsp; at java.security.AccessController.doPrivileged(Native Method)<br />&nbsp;&nbsp;&nbsp; at foxtrot.AbstractWorkerThread.runTask(AbstractWorkerThread.java:45)<br />&nbsp;&nbsp;&nbsp; at foxtrot.workers.DefaultWorkerThread.run(DefaultWorkerThread.java:153)<br />&nbsp;&nbsp;&nbsp; at java.lang.Thread.run(Unknown Source)<br /><br />Message: na<br />-------------------------------------------------------------<br />java.lang.Throwable: na<br />&nbsp;&nbsp;&nbsp; at edu.mit.broad.xbench.core.api.AbstractWindowManager.showError(AbstractWindowManager.java:72)<br />&nbsp;&nbsp;&nbsp; at org.genepattern.gsea.XToolsMessageHandler.showErrorDialog(XToolsMessageHandler.java:33)<br />&nbsp;&nbsp;&nbsp; at org.genepattern.uiutil.UIUtil.showErrorDialog(UIUtil.java:41)<br />&nbsp;&nbsp;&nbsp; at org.genepattern.gsea.LeadingEdgeWidget.runAnalysis(LeadingEdgeWidget.java:327)<br />&nbsp;&nbsp;&nbsp; at org.genepattern.gsea.LeadingEdgeWidget.access$000(LeadingEdgeWidget.java:59)<br />&nbsp;&nbsp;&nbsp; at org.genepattern.gsea.LeadingEdgeWidget$1.actionPerformed(LeadingEdgeWidget.java:129)<br />&nbsp;&nbsp;&nbsp; at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at javax.swing.DefaultButtonModel.setPressed(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.Component.processMouseEvent(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at javax.swing.JComponent.processMouseEvent(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.Component.processEvent(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.Container.processEvent(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.Component.dispatchEventImpl(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.Container.dispatchEventImpl(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.Component.dispatchEvent(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.Container.dispatchEventImpl(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.Window.dispatchEventImpl(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.Component.dispatchEvent(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.EventQueue.dispatchEvent(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.EventDispatchThread.pumpEvents(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.EventDispatchThread.pumpEvents(Unknown Source)<br />&nbsp;&nbsp;&nbsp; at java.awt.EventDispatchThread.run(Unknown Source)<br /><br /><br /><span style="font-weight: bold;"><span style="font-weight: bold;"><br />Notes from user tests 3/31<br /></span></span><br />Needs java1.5<br />So if you launch on a mac and see the error message unsupported class version it means that your mac (or windows) doesnt not have the correct java version.<br />For the mac: http://docs.info.apple.com/article.html?artnum=302412<br /><br /><span style="font-weight: bold;"><span style="font-weight: bold;"><br />Feature Additions for build 3/2</span>8<br /><br /></span>1. Leading edge interactive viewer includes HTML report option<br />2. Installer works: Download new version from: <span style="color: rgb(255, 0, 0);">XXX</span><br />3. New msigdb xml file and gene set cards created. Gene set descriptions cleaned up. Anything odd is now a bug.<br />4. I'll be adding to the software version 2 release notes wiki page (pl subscribe and edit as needed).<br />5. Unified application messages (they are all now in the status bar at the bottom), no more system console viewer<br />6. Added a splash screen so that users know the application is loading after its desktop application has been double clicked<br />7. Implemented the startup screen (let me know what you think of its content)<br />8. For the chip platform parameter, multiple chips can be selected (for example if a dataset is made from 2 different chips). <br />9. By default the hyperlinks from the software will point to the PROD server. To make them connect to the DEV server, use the -Ddebug=true flag<br /><br /><br /><span style="font-weight: bold;">Found/requested 3/27 (with installed Gsea2):<br /></span><br />1. From the Load Data page: load a gene set matrix, use Extract Gene Sets to create gene sets in memory, use Create Ranked List to create a ranked list from one of those gene sets. It tells me that it created the ranked list and gives me the following info messages, but I can't find the ranked list: it's not in the default output folder, the object cache list, or the drop-downs on the PreRanked GSEA page. <br /><br />1355 [INFO ] Starting: =&gt; Extract GeneSets from the GeneMatrix<br />1385 [INFO ] Successfully created a GeneSet from the Dataset s2_gene_set_database.diabetes.gmt into: 323 gene sets<br />1425 [INFO ] Null widget - no window opened<br />9346 [INFO ] Starting: =&gt; Create a RankedList<br />9366 [INFO ] Successfully created a RankedList from the GeneSet 41BBPATHWAY into: 34 members<br />9366 [INFO ] Null widget - no window opened<br /><br style="color: rgb(255, 102, 0);" /><span style="color: rgb(255, 102, 0);">I fixed this but then rmoved the action - because i wondered if converting a gene set to a ranked list would cause confusion b/w what a gene set is and what a ranked list is. Thoughts?<br /><span style="color: rgb(0, 0, 255);">Agreed; I removed it from the doc.</span><br style="color: rgb(255, 102, 0);" /></span><br />2. On the Leading Edge Report page, I built a report, realized I built the wrong one, so selected and built a different one. A new tab appears, but it doesn't get the focus (so I didn't notice it at first). Also, the tabs that get created should have close (X) icons.<br /><span style="color: rgb(51, 153, 102);">Pl ask Josh; <span style="color: rgb(0, 0, 255);">sent him email</span></span><br /><br />3. The output folder creates a subfolder for each day (mar21, mar22, etc). Shouldn't the folder name include the year? Or, do we expect people to be deleting the reports on a regular basis?<br /><br /><span style="color: rgb(255, 102, 0);">Good point. But folder names are key to a lot of things and i'm wary of changing the convention at this stage.<br /><span style="color: rgb(0, 0, 255);">Sounds reasonable. We can decide whether to change it or doc it in the next release (doc=recommend that people periodically delete old reports, renaming and saving what they want to keep).</span></span><br /><br />4. On the Run GSEA page, select phenotypes, on the Select one or more phenotypes window, the button should be Create <span style="text-decoration: underline;">an </span>on-the-fly phenotype... rather than Create <span style="text-decoration: underline;">a </span>on-the-fly phenotype.... <br /><span style="color: rgb(51, 153, 102);">Fixed</span><br /><br /><span style="font-weight: bold;">Found/requested 3/24 (with installed Gsea2):<br /></span><br />1. Names generaed by GSEA were too long for Windows. My personal profile failed to load and I was logged in with a temporary. Had to zip (and delete) one of my GSEA report folders before I could log into Windows with my own profile. Put the zipped reports folder in dropbox/foraravind.<span style="font-weight: bold;"><br /><br style="color: rgb(255, 0, 0);" /><span style="color: rgb(255, 0, 0);">IMPortant to fix. <span style="color: rgb(51, 153, 102);">Fixed</span><br /><span style="color: rgb(0, 0, 255);">Is this impossible to fix or important to fix?</span><br /></span><br /><br />Found/requested 3/22 (with installed Gsea2):<br /></span><br />1. I expected chip or no chip specified to determine whether gene symbols/titles showed up in gene set detail report. Ran GSEA with p53, native, no chip, and got no gene symbol as expected. Added chip and got gene symbol as expected.<span style="font-weight: bold;"><span style="font-weight: bold;"> </span></span>But, then removed chip and still got the gene symbols (as if they were stored in memory or something). Parameters on the report confirm that I did not have chip specified. All three reports (nochip, chip, and chip_nochip) are in dropbox/foraravind.<br /><br /><span style="color: rgb(0, 0, 255);">Indeed, if you set chip once for a dataset, the program remembers this association during the current session.<br /><span style="color: rgb(255, 102, 0);">Doc'd.</span><br /></span><br />2. Created my own gene set file, one gene set with text description and another with URL. Ran GSEA. The Enrichment Result report tries to link my gene sets to MSigDB rather than using my descriptions. (That report also on the dropbox/foraravind.)<br /><br /><span style="color: rgb(51, 153, 102);">Fixed (note: it was clumsy to place a desc text in the table as it could be very long. So, the 2 modes are: 1) na in the desc field of the gmx /gmt file -&gt; auto links to msigdb. 2) a valid url i.e text that starts with http &gt; links to the custom http ... site specified<br /><span style="color: rgb(255, 102, 0);">Doc with file formats.</span><br /></span><br />3. On Leading Edget report, when I click select reports from application cache, I expected to get today's reports (the ones in the Object Cache list on the Load Data page). Instead, I get a list of all reports, neatly arranged by date, excluding todays. When I run reports, they appear in the Object Cache as I expect.<br /><br /><span style="color: rgb(0, 0, 255);">This is a 'feature'. The object cache lists the programs memory&nbsp; while the leading edge cache lists the file system - i.e all analysis ever done (which could be too large to load into memory).<br /><span style="color: rgb(255, 102, 0);">Doc'd</span><br /></span><br />4. Run GSEA using the new Gene Matrix from web site tab to select the C2 gene sets. Analysis fails due to duplicate gene sets.<span style="font-weight: bold;"><span style="font-weight: bold;"><br /><br /></span></span><span style="color: rgb(51, 153, 102);">Fixed (new gene sets database)<br /><br /></span>5. On the new error handling, when I click the red error in the processes box, it should automatically open the console viewer and show me the error. It took me a litle bit to realize that I had to Click for details... to open the console and then click Error to see the error.<br /><br /><span style="color: rgb(51, 153, 102);">Fixed<br /><br /></span>6. Analysis History page still isn't showing up for me. <br /><br /><span style="color: rgb(51, 153, 102);">Fixed</span><br /><br />7. On MSigDB page, when I click export, I'm expecting to export what I have displayed in the table on the MSigDB page. When I selected All Items, I thought that meant all items displayed in the table; it seems mean all items in the MSigDB? (thanks for going back to one button)<br /><br /><span style="color: rgb(51, 153, 102);">Fixed</span><br /><br />8. RunGSEA form, the normalization parameter, you were going to delete the varmean option (or at least change the current name VarMeanPosNegSeparate back to varmean).<br /><br /><span style="color: rgb(51, 153, 102);">Fixed<br /><br /></span>9. On the Algorithms page of the Preferences window, delete the phrase &quot;(they can also be changed in params)&quot; -- only one of them can.<br /><br /><span style="color: rgb(51, 153, 102);">Fixed<br /><br /></span>10. Run GSEA, add a phenotypes file, create phenotypes on the fly (works fine), click the Show Phenotypes from all Sources. Should show labels from both the file you added and the one you just created, but now shows only one at a time. (This seems to have broken in the 3/21 build; I'm pretty sure it was working in the 3/20 build).<br /><br /><br /> 11. On the GSEA analysis report:&nbsp; Indent the phenotype permutation warning (or make it another bullet) so it looks more like part of the &quot;Other&quot; section. Also, remove the message at the&nbsp; bottom: &quot;# of genesets before size filtering: 3 and # of genesets after size filtering: 3&quot; (that info is already in the &quot;Gene set details&quot; section of the report).<br /><br /><span style="color: rgb(51, 153, 102);">Fixed<br /><br /></span>12. Leading Edge Viewer looks good! Two things: (1) The bottom two viewers have zoom controlled by CTRL+[ and CTRL+], but I can't get the focus to the right-hand viewer. The CTRL sequence always zooms the left viewer.&nbsp; (2) The viewers completely replace the old HTML report, which included the details of gene sets used (name, # of members, # of members in signal, tag%, list%, signal strength). That info seems useful and now lost? (The 2nd viewer (the set-to-set comparison) has a nice open spot for a &quot;Display gene set details&quot; button...)<span style="font-weight: bold;"><span style="font-weight: bold;"><br /><br /></span></span><span style="color: rgb(0, 0, 255);">Josh is adding 2) and can help fix 1). <span style="color: rgb(255, 102, 0);">sent email</span></span><br /><span style="font-weight: bold;"><span style="font-weight: bold;"><br /><br /><br />Feature Additions for build 3/2</span>1<br /><br /></span>1. Leading edge interactive viewer<br />2. Added a preferences field for path to user home dir.<br />3. made native the default space in gsea. Not sure if this is better??<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<span style="color: rgb(0, 0, 255);"> I prefer gene_symbol since that's what we recommend. </span><span style="color: rgb(51, 153, 102);">Fixed</span><br />4. default collection of gene sets available via ftp<span style="font-weight: bold;"><br /><br /><span style="font-weight: bold;">Found/requested 3/17:</span><br /><br /></span>1. Add Command button to Leading Edge page.<br /><br /><span style="color: rgb(255, 0, 0);">Cant do this easilly because of the way the command thing is setup.<br /><span style="color: rgb(0, 0, 255);">You said you could do this after all.<br /><span style="color: rgb(255, 102, 0);">Na anymore because of Joshs improved interactive impl</span></span><br /></span><br />2. Leading edge from command line give me fatal errors:<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 719&nbsp; [FATAL] Could not make dir: C:\Documents and Settings\hkuehn\.xtools_home\databases&nbsp;&nbsp;&nbsp; at <br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; edu.mit.broad.xbench.core.api.VdbManagerImpl._mkdir(VdbManagerImpl.java:89)<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 719&nbsp; [FATAL] Could not make dir: C:\Documents and Settings\hkuehn\.xtools_home\chip2chip&nbsp;&nbsp;&nbsp; at&nbsp;&nbsp; <br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; edu.mit.broad.xbench.core.api.VdbManagerImpl._mkdir(VdbManagerImpl.java:89)<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 799&nbsp; [FATAL] Could not make dir: C:\Documents and Settings\hkuehn\.xtools_home\reports_cache_foo&nbsp;&nbsp;&nbsp; at<br />&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&nbsp; edu.mit.broad.xbench.core.api.VdbManagerImpl._mkdir(VdbManagerImpl.java:89)<br /><br />Must set -DGSEA=true flag<br />So,<br /><br /> <pre>java -Xmx ... -DGSEA=true xtools.....</pre> <br /><br />3. MSigDB page, the Find sets that Overlap search gives page with no Export button; make that page more like the<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Find sets that contain this gene page.<br /><br /><span style="color: rgb(255, 153, 0);">Joshs reworked impl will replace this and the export option should be added to it</span><br /><br />4. On Run GSEA, change parameter name from &quot;Analyze in the feature space&quot; to &quot;Gene/probe identifier format&quot;<br /><br /><span style="color: rgb(255, 0, 0);">Lets talk. <span style="color: rgb(0, 0, 255);">Forgot to bring this up in our last chat.<br /><span style="color: rgb(255, 102, 0);">What about using &quot;Collapse dataset&quot; as the name, where values are True (use 'chip' to collapse dataset to gene symbols) and False  (blah blah).</span><br /></span></span><span style="color: rgb(51, 153, 102);">Fixed<br /><br /></span>5. Remove Downloads&gt;Download Gene Sets (no longer needed now that we have MSigDB page).<br /><br /><span style="color: rgb(51, 153, 102);">Done <span style="color: rgb(255, 102, 0);">Doc'd</span></span><br /><br />6. Change first two Help items to &quot;GSEA web site&quot; and &quot;GSEA documentation&quot;. First points to home page of web site and<br />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; second points to the doc page of the web site.<br /><br /><span style="color: rgb(51, 153, 102);">Done <span style="color: rgb(255, 102, 0);">Doc'd</span></span><br /><span style="font-weight: bold;"><br /><span style="font-weight: bold;">Bugs found 3/15/2006 include:</span><br /><br /></span>1. Generate a report, go to &quot;Other&quot; section, look at parameters. Error, file cannot be found.<br /><br /><span style="color: rgb(51, 153, 102);">Fixed</span>.<br /><br />2. Started a pretty long analysis, killed it. It took a few minutes versus a few seconds. If that's expected, perhaps change message to say may take a few minutes.<br /><br style="color: rgb(255, 102, 0);" /><span style="color: rgb(255, 102, 0);">Whats a long analysis? (for leading edge clustering more than a handful of sets, say 20, is likely pointless)</span><br /><br />3. Leading edge report brings up the gct files in a text editor rather than Excel; can't really read them in a text editor.<br /><br /><span style="color: rgb(255, 102, 0);">Opening gct files now works like this: First check prefs to see if excel (or the other programs) exist at location indicated in the prefs. If so, use it. Otherwise issue a generic open file command in windows that will open up the file in whatever editor has been registered by windows for that file type. On the mac, the later mode is always done. On unix i dont know what will happen.</span>
+
<p><span style="font-weight: bold;"><br /></span>We are now using [http://bugzilla.broad.mit.edu/gsea/ Bugzilla]  to record and track GSEA bugs. <br /></p>
 +
<p>Bugs from this page that were verified/rejected before we started using Bugzilla, can be found in  [http://wwwdev.broad.mit.edu/gsea/doc/GSEA_enh_history.doc GSEA_enh_history.doc].<br /><span style="font-weight: bold;"></span><span style="color: rgb(255, 0, 255);"></span><br /></p>

Current revision as of 19:04, 16 May 2006


We are now using Bugzilla to record and track GSEA bugs.

Bugs from this page that were verified/rejected before we started using Bugzilla, can be found in GSEA_enh_history.doc.

Personal tools